Framework crashes on startup on WP7

Nov 12, 2011 at 3:05 PM

I was porting the 'Ace on Steroids' source over to WP7 and managed to get it to compile, but the game crashes upon launch. Thinking it might be specified to the project, I started a new project and modified Game1 to derive from the IGF Application class. Same problem. I've tested this on both WP7.0 and WP7.1, and even on my device. None are having success in starting the game.

Does anyone have any success in using IGF on WP7? I'm not sure if it's the framework or just me, so I'm not filing this in the Issue Tracker yet.

This is what I got upon launch:

'taskhost.exe' (Managed): Loaded 'mscorlib.dll'
'taskhost.exe' (Managed): Loaded 'System.Windows.RuntimeHost.dll'
'taskhost.exe' (Managed): Loaded 'System.dll'
'taskhost.exe' (Managed): Loaded 'System.Windows.dll'
'taskhost.exe' (Managed): Loaded 'System.Net.dll'
'taskhost.exe' (Managed): Loaded 'System.Core.dll'
'taskhost.exe' (Managed): Loaded 'System.Xml.dll'
'taskhost.exe' (Managed): Loaded '\Applications\Install\4E4FD1B8-BD5B-4DD4-AD42-39EB0015A0F1\Install\Ace on Steroids.dll', Symbols loaded.
'taskhost.exe' (Managed): Loaded 'Microsoft.Xna.Framework.Game.dll'
'taskhost.exe' (Managed): Loaded 'Microsoft.Xna.Framework.Graphics.dll'
'taskhost.exe' (Managed): Loaded 'Microsoft.Xna.Framework.dll'
'taskhost.exe' (Managed): Loaded 'Microsoft.Phone.Interop.dll'
'taskhost.exe' (Managed): Loaded 'Microsoft.Phone.dll'
'taskhost.exe' (Managed): Loaded '\Applications\Install\4E4FD1B8-BD5B-4DD4-AD42-39EB0015A0F1\Install\Indiefreaks.Game.Framework.dll'
A first chance exception of type 'System.InvalidOperationException' occurred in Microsoft.Xna.Framework.Game.dll
'taskhost.exe' (Managed): Loaded 'Microsoft.Xna.Framework.GamerServices.dll'
The thread '' (0xef50042) has exited with code 0 (0x0).
The thread '' (0xe090042) has exited with code 0 (0x0).
The program '[236781634] taskhost.exe: Managed' has exited with code 0 (0x0).
Nov 12, 2011 at 10:32 PM

I've seen this when the Sunburn dll reference hasn't been set to CopyLocal = true.

Nov 13, 2011 at 5:29 AM

Changing CopyLocal worked like a charm! Thanks!